Der M4E-K(r)ampf auf Nokia E51

Hui. Das war eine schwere Geburt. Seit Wochen funktionierte der Abgleich meines Nokia E51 mit dem Exchange Server meines Arbeitgebers nicht mehr. E-Mails kamen noch an, aber keine Kalenderdaten mehr. Ich dachte mir, dass ein Update von Mail for Exchange auf die aktuelle Version der Weisheit letzter Schluss sei. Aber mit der Version 3.0 wurde es noch schlimmer. Nun löschte mein Handy alle E-Mails, die es beim letzten Sync empfangen hatt, legte von vorne los bis es wieder auf einen Fehler traf und dann die Sache abbrach. Das wiederholte sich nun alle 15 Minuten, mit der Folge, dass der Akku in 24 Stunden leergelutscht war. Zu doof.

Mail for Exchange meldete übrigens nur lapidar: Fehler in Exchange Server. Versuchen Sie es später erneut. Aber was soll man denn damit anfangen. Ich habe dann in den Logs des IIS und auf dem Handy geforscht, aber auch da keine brauchbaren Hinweise auf die Ursache gefunden. Die Suche in diversen Foren brachte mich aber letztendlich auf den richtigen Pfad. Im Kalender war eine kaputter Termin(-datensatz). Durch das Verschieben aller meiner Termine von meinem „normalen“ Outlook-Kalender in ein Kalenderordner in einer PST-Datei und wieder zurück, konnte ich diesen ermitteln und Löschen. Genauso bin ich natürlich auch mit den E-Mails und Aufgaben vorgegangen.

Nun konnte ich die Kalenderdaten wieder synchronisieren, dafür aber keine E-Mails mehr! Der E-Mailtransfer bracht mit der Meldung „Systemfehler. Versuchen sie es später erneut.“ ab. Ach ja, wie hilfreich. Zu guter letzt habe ich M4E auf dem Handy neu installiert und dann hat alles wieder geklappt. Puuh.